Eclipse Helios will not start on RHEL v6.4

If you happen to run an older version of Eclipse (v3.6) – such as the case with IBM Operational Decision Manager v8.5 – on Linux RHEL v6.4, you might encounter the following GPF as Eclipse starts:

----------- Stack Backtrace ----------->
(0x00000035F020E01C [ld-linux-x86-64.so.2+0xe01c])
(0x00000035F0214715 [ld-linux-x86-64.so.2+0x14715])
(0x00007FB7FAD1783F [libxul.so+0x11ca83f])
(0x00007FB7FAD3E497 [libxul.so+0x11f1497])
(0x00007FB7FAD40269 [libxul.so+0x11f3269])
(0x00007FB7FAD404AD [libxul.so+0x11f34ad])
(0x00007FB7FAD40EB0 [libxul.so+0x11f3eb0])
NS_InitXPCOM2_P+0x3f8 (0x00007FB7FAD1ADD2 [libxul.so+0x11cddd2])
Java_org_eclipse_swt_internal_mozilla_XPCOM__1NS_1InitXPCOM2+0x12 (0x00007FB8699EDA3E [libswt-mozilla-gtk-3659.so+0x6a3e])
(0x00007FB87E28C75F [libj9vm26.so+0x3375f])

To fix it, edit your eclipse.ini file, and add the following at the bottom:
-Dorg.eclipse.swt.browser.UseWebKitGTK=true

Advertisements
Eclipse Helios will not start on RHEL v6.4

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s